Norwegian users may be unable to make new purchases with Klarna checkout
Incident Report for Mystore.no
Resolved
This incident has been resolved.
Posted 14 days ago. Jul 10, 2019 - 18:09 CEST
Investigating
Due to an incident at a third party provider we are currently having problems affecting consumers in Norway who may not be able to make new purchases. This is being worked on but there is so far no estimate as to how long it's going to take to solve. We apologise for the inconvenience this may cause.
Posted 14 days ago. Jul 10, 2019 - 13:46 CEST